[Unstrung-hackers] sunshine with 1.10

Vijay Anand R vjanandrgky at gmail.com
Mon Oct 26 13:08:44 EDT 2015


tried latest after the patch I am still hitting the asssert condition...

Details you asked for below...

64 bit build diffs -- > http://pastebin.com/Hycxw57x
git log -- > http://pastebin.com/uYbRTiuf
libboost/ubuntu version --> http://pastebin.com/Bgwj5xzJ


196 => sudo sunshine -G unstrung -I 0 -R 1 --ignore-pio --dao-if-filter 
gre_test_* --dao-addr-filter fd08::/16 -i acp-loopback0
PANDORA unstrung version 1.0 (20151026_1445843655) starting at Mon Oct 
26 14:17:32 2015
link found[1]: lo type=loopback (inactive new)
link found[2]: eth0 type=ether (inactive new)
link found[3]: eth1 type=ether (inactive new)
link found[4]: eth2 type=ether (inactive new)
link found[5]: docker0 type=ether (inactive new)
link found[6]: dummy0 type=ether (inactive new)
link found[7]: snbi-fe type=ether (inactive new)
link found[8]: ip6tnl0 type=tunnel6 (inactive new)
link found[9]: ip6gre0 type=[823] (inactive new)
link found[10]: gre_test_tunnel type=[823] (inactive new)
link found[11]: acp-loopback0 type=ether (inactive new)
ip found[1]: lo scope=254 address=::1
ip found[2]: eth0 scope=253 address=fe80::20c:29ff:fe62:2675
ip found[3]: eth1 scope=0 address=fd08:2eef:c2ee:0:aabb:cc00:c900:3
ip found[3]: eth1 scope=253 address=fe80::20c:29ff:fe62:267f
ip found[4]: eth2 scope=0 address=fd08:2eef:c2ee:0:aabb:cc00:c900:4
ip found[4]: eth2 scope=253 address=fe80::20c:29ff:fe62:2689
ip found[7]: snbi-fe scope=253 address=fe80::2064:a5ff:fe5b:16bf
ip found[10]: gre_test_tunnel scope=0 
address=fd08:2fff:c2ee:0:aabb:cc00:c900:1
ip found[11]: acp-loopback0 scope=0 
address=fd08:2eef:c2ee:0:2e19:ba2d:e05f:11
ip found[11]: acp-loopback0 scope=253 address=fe80::74c2:74ff:fe0f:4b7b
resetting ipv6-allrouters membership on acp-loopback0
sunshine: 
/home/snbi-tb-b/unstrung-unstrung-1.10/include/boost/heap/binomial_heap.hpp:325: 
boost::heap::binomial_heap<T, A0, A1, A2, A3>::const_reference 
boost::heap::binomial_heap<T, A0, A1, A2, A3>:
:top() const [with T = rpl_event*; A0 = 
boost::heap::compare<rpl_eventless>; A1 = boost::parameter::void_; A2 = 
boost::parameter::void_; A3 = boost::parameter::void_; 
boost::heap::binomial_heap<T, A0,
  A1, A2, A3>::const_reference = rpl_event* const&]: Assertion 
`!empty()' failed.


On 10/26/2015 8:59 PM, Vijay Anand R wrote:
> Sure will try with this patch...
>
> could you please clarify the different between --dao-if-filter and -i 
> option ?
> sudo sunshine -G unstrung -I 0 -R 1 --ignore-pio --dao-if-filter 
> gre_test_* --dao-addr-filter fd08::/16 -i acp-loopback0
>
> On 10/26/2015 8:46 PM, Michael Richardson wrote:
>> Vijay, I think that Brad also found the same problem, and appears to 
>> have
>> fixed it:
>>        https://github.com/mcr/unstrung/pull/15
>>
>> -- 
>> ]               Never tell me the odds!                 | ipv6 mesh 
>> networks [
>> ]   Michael Richardson, Sandelman Software Works        | network 
>> architect  [
>> ]     mcr at sandelman.ca  http://www.sandelman.ca/        |   ruby on 
>> rails    [
>>
>



More information about the Unstrung-hackers mailing list